Forum

Glow Issue with FireFox 35 and 36

14 January 2015 23:01 #1067
When I have an object with "m_scenes.apply_glow_anim_def(obj);" The entire screen will display in my glow color. This also breaks your Tutorial "Setting a Room".
15 January 2015 12:43 #1070
Yes, we could reproduce this error on Windows in Firefox 35, thanks for reporting. Investigating now..
Development Lead | Twitter
15 January 2015 17:49 #1072
Apparently almost all postprocessing effects are broken in Firefox 35/Windows. Linux and Mac work fine. We'll implement a workaround for the upcoming release. Meantime, you can just enable alpha in the init() function and this will do the trick:

m_app.init({
    canvas_container_id: "main_canvas_container",
    callback: init_cb,
    alpha: true
});

Development Lead | Twitter
15 January 2015 18:34 #1074
Thanks, for the quick fix.
We've noticed other issues with our HTML 5 based course engine because of the is update (Not necessarily Blend4Web). Seems like there are lots of issues with the new FireFox updates.
20 January 2015 21:20 #1122
I was just going to report the same issue, did not know it was the glow color, thanks for the info.

fyi, enabling Alpha disables the background color in firefox, replacing it with the glow color


m_app.init({

alpha: true,
background_color: [0.7, 0.9, 1.0, 0.0]
});
http://www.trepaning.com
22 January 2015 14:19 #1133
fyi, enabling Alpha disables the background color in firefox, replacing it with the glow color
I wasn't able to reproduce this issue in Firefox 35 on Windows. Probably you've reloaded your app from the cache?
Blend4Web developer
22 January 2015 20:41 #1137
Just ran a localhost test.

Setting alpha to TRUE makes background GLOW color, in this case, WHITE.

Setting alpha to FALSE makes background nice light BLUE color, as specified in the code.

Consistent issue, just change TRUE to FALSE.

Here are the files LINK DISABLED
http://www.trepaning.com
23 January 2015 11:09 #1141
I've checked your files. It really may seem like a bug but it's not

When alpha is turned on our result image starts mixing with the underlying html-elements in the areas where it (WebGL image) is not fully opaque. So, as the background color is transparent, you are getting the color of <body> which is white by default (almost like your glow color).

The easiest solution is to set background color alpha component to 1.0.
m_app.init({
    background_color: [0.7, 0.9, 1.0, 1.0],
});
Blend4Web developer
23 January 2015 20:34 #1153
Awesome, thanks for the info.

As for this current Firefox issue, I would suspect it is a Firefox problem to remedy as opposed to a B4W workaround to be implemented. Let me know if it is otherwise, as I am essentially ceasing development for the time being if glow is knocked out of the pipeline for 2 major browsers.
http://www.trepaning.com
23 January 2015 21:24 #1154
As for this current Firefox issue, I would suspect it is a Firefox problem to remedy as opposed to a B4W workaround to be implemented.
Yes, it is a Firefox bug. However, we'll include a temporary workaround in the upcoming B4W release in order to solve it.
As for Internet Explorer and other cases when depth textures are missing and the low quality is enforced, we are now implementing a fallback (namely, packing depth values in RGBA channels) in order to support glow and other post-processing effects.
Development Lead | Twitter
 
Please register or log in to leave a reply.