Forum

Matcap texture with nodes (Geometry => normal)

14 July 2017 20:13
Hello,
i followed this tutorial on Youtube (https://www.youtube.com/watch?v=IPUUtGNamfU) about setting a matcap as a texture. It works good without nodes, but with nodes it only works in the Blender 3D viewport but not in the Web Browser.
I recorded a GIF screen capture in attach.
15 July 2017 03:02
Hello,
i finally found how to obtain the same matcap effect with nodes.
I added a "Vector Transform" Node with this setting : ( Transform : Normal + From : "World" + To : "Camera" ),
the result in the web browser is as expected but in the Blender 3D viewport it's not the final effect of the web browser.
I share the .blend file with the matcap image for trying.
17 July 2017 11:42
Hi!

You need to choose " Set Recommended Options" under Render tab:




Blender shows other normals' settings by default. Pressing that button will put Viewport rendering as close as possible toWebGL rendering
3D Generalist, contests administrator,
Blend4Web team.
art blog: http://contret-art.tumblr.com/
17 July 2017 22:14
Reply to post of user Pavel Kotov
Hi!

You need to choose " Set Recommended Options" under Render tab:




Blender shows other normals' settings by default. Pressing that button will put Viewport rendering as close as possible toWebGL rendering

Yeah !! what a Wizzard trick ! in this case just the "World Space Shading" checkbox is enough to correct the normal shading issue ;-)
Thanks a lot Pavel Kotov for this tip ;-)
 
Please register or log in to leave a reply.