Problems with MacOS 10.13.5

13 June 2018 01:45
I have Blend4web installed in a MacBook Pro and a MacPro, both with MacOS 10.13.5. In the Macbook Pro, Blend4web 18.05.0 works just fine. By contrary, in the MacPro, while the previous version worked just fine, the 18.05.0 version does not work. It's impossible to open the Project Manager or use the Fast Preview. When using the Fast Preview it occurs the error that appears in the attached image.
Any ideas?

14 June 2018 12:17
Could you try to run the server from the terminal?

cd path_to_blend4web
python3 scripts/

Then open http://localhost:6687
If it will work, you can use it as workaround.

Currently we have some troubles with update of our MacOS-device. As soon as we update, I think we will be able to reproduce the issue.
Alexander (Blend4Web Team)
15 June 2018 04:06
Hi Alexander

The solution solved the Fast Preview access. It's working now. However it's still impossible to access the Project Manager. We click but nothing happens.
Thank you so much and tell me if you need me to test any other solution.
Best Regards
15 June 2018 11:27
Have you tried direct link to the Project Manager? http://localhost:6687/project/
Alexander (Blend4Web Team)
16 June 2018 02:12
Hi Alexander

The project manager it's also working via http://localhost:6687/project/ after entering the terminal commands

cd path_to_blend4web
python3 scripts/

It would be great if these steps could be skipped.
It's also strange how everything it's working in my MacBook Pro but not in the MacPro with the same system.
Beyond these small hiccups, this is a great update.
16 June 2018 02:27
Hi again Alexander

Ekaterina Leonidova's solution worked just fine.
Thank you so much

Users can find this solution into News and Announcements -> Developer Preview 18.05

Maybe you could create a new topic for this issue.
07 November 2018 07:09
I just had the same issue, however, I am using a MacbookPro. See attached images.

Cannot open Project Manager nor use the Fast Preview. btw. The only Fast preview button is within the render tab on properties panel. There is no Fast Preview button displayed in the modeling UI as with the B4W addon.

I'm not one to tinker in Terminal, but I will see what I can do. Unless there is an update that I am not aware of.

MBP - 10.11.6
Blender 2.79
B4WCe - 18.05.0
01 February 2019 06:08
I have also faced the same problem with the MAC and what I actually did is directly consult with Fix Windows update error code 8007000e and follow the tips mentioned here. It was really very effective to solve the error.
Please register or log in to leave a reply.