Installation Error "Depreciated paths to Scripts....."

28 February 2016 21:41 #7829

Trying to install SDK version and I get error message "Depreciated paths to Scripts….." even though it appears my paths are correct (image 1). I assumed the addon is included with the SDK files (but maybe not because…). Basically my steps were: I installed the folder blend4web_sdk_free to my C:\ drive. When trying to select the addon it does NOT show in my UserPrefs..Import/Export panel… So "Plan B": I tired to install it manually by downloading and installing the addon separately, but then I keep getting "Depreciated Path to Scripts" Error (image 1). HOWEVER. When I change the scripts path (see image 2) that error goes away – but something is still wrong because I am not getting the "Development Server / Open SDK" to show when I select Blend4Web engine as seen in the 3rd image (taken from the installing video screen shot).

Hello from Sunny Los Angeles!
29 February 2016 05:20 #7837
For the path to Scripts, choose this:

The file path may vary, depending on where you keep your SDK. But basically, point it to the SDK's root directory.
In older versions of Blend4Web the file path was different, and that's why you saw the "Deprecated path to scripts" error message.

Save User Settings and Quit Blender.

Relaunch Blender, go to your Add-Ons tab in Preferences, and enable the Blend4Web SDK.

If you expand Blend4Web's listing in the Add-Ons list, there is another file path to check. Set this to be the same file path as above. Save User Settings again.

For more details, see the Blend4Web Manual's section on Installing the SDK.
29 February 2016 05:36 #7838
Thank for your reply.

However per "basically, point it to the SDK's root directory."
1) Image 1 above shows the path to my root directory on C drive where the files are:
If I remove the "blender_scripts" from that path it makes no difference.

2) I don't get a "Blend4Web SDK." listed. I ONLY get Blend4Web.

Sorry.. don't mean to be dense.

Hello from Sunny Los Angeles!
29 February 2016 05:44 #7840
1) Are you sure that is the new version of the SDK and not the old one?
Also, remember to relaunch Blender for it to take effect. What this part does is, it makes the B4W (SDK) add-on visible in Blender's add-ons list.

2) Is it possible you did a quick install of only the standalone add-on and not the SDK? (In other words, this)
If so, you need to uninstall the standalone add-on and install the SDK properly from the beginning.

(No need to apologize - I was confused the first time I did it too.)
29 February 2016 06:43 #7842
Because I've done this a couple times and I'm still not getting a resolution –I'm going to start over from the beginning –again. But Yes. I initially installed the stand alone. And yes.. I have Ver 16.02

To make sure I am doing it it right though –to uninstall all I have to do is go to addons and select Blend4Web and click remove –right? Restart Blender. Double checked and it's not there. There's no where else I have to delete other files right?

Redoing the SDK steps and here's where things are at now – I should be good to go right? Except I still don't get the Open SDK button nor does the Preview in Viewer show up as an option when exporting.

My directory structure:

Hello from Sunny Los Angeles!
29 February 2016 08:12 #7845
SUCCESS! It does not show in my panel at the top. And because I had other drop downs open it was buried at the bottom.

So the Dev Server is running as seen here:


HOWEVER – last issue? Error message when I click "Fast Preview (see below) AND I still don't get the Preview in Viewer option when I go to export.

Thanks for being so patient.

Hello from Sunny Los Angeles!
29 February 2016 09:24 #7849

HOWEVER – last issue? Error message when I click "Fast Preview (see below) AND I still don't get the Preview in Viewer option when I go to export.

Oh… THAT. I've run into that error before. It's absolutely annoying because you have to uninstall (by removing the add-on first), then re-install (yet again) the SDK.
And just to be sure, you should probably re-download it in case something inside has become corrupt. And before installing it again, check your add-ons folder to make sure nothing relating to Blend4Web is still lingering. But it is fixable.

I believe this happens when an update is done incorrectly. You can see my thread about it here, and another person's thread here. In both cases reinstalling fresh was the solution.

By the way, for future reference, when updating I think the best way is to follow these steps you can use Git to update Blend4Web, and this is probably the easiest way. Read Konstantin's second comment in this thread for details. If not using Git, you can do this:

1) Export any projects you want to keep. Close the Project Manager page when you're done.

2) Disable the Blend4Web add-on from Blender's Preferences. Save User Settings, and Quit Blender.

3) Move your old SDK folder to the Trash/Recycle Bin (no need to empty it just yet).

4) Move the new SDK version's .zip file to the location you want to keep it in, and unzip it.

5) Launch Blender, check that the file path for the scripts folder is correct. (It should be the root folder of the SDK.) Save User Settings, and Quit Blender.

6) Launch Blender again and enable the Blend4Web add-on. It should show the new version number. Save User Settings.

7) Switch to the Blend4Web Engine and test that the Fast Preview feature is working.

8) From Blender, launch the Project Manager again. Import your projects back in.

9) Empty your system's Trash/Recycle Bin (optional, of course). Might want to make sure your re-imported projects are working correctly first, just to be certain.
29 February 2016 21:32 #7883
i did all those steps exactly, downloaded it all over again – and I still get the same error message and no Preview in Viewer option when exporting. Actually it's worse now because when I clcik to start Project Manager all the image thumbnails are gone on the initial page and when I clcik on a link, say for example the first one: dev: cartoon_interior.html I get a 500 Internal Server Error message in my browser window. I give up stabbing myself in the head. :) But hey, at least it's kind of working… but this insanity def kills any enthusiasm for learning it. They need to get this sorted out –I've been using computers for 25 years (so I'm not a complete idiot at least) and haven't spent this much time with crazy applications in a LOOOONG time. Thanks for your help.

Hello from Sunny Los Angeles!
29 February 2016 22:52 #7887

500 Internal Server Error message
Please see this topic on how to fix that
Development Lead | Twitter
29 February 2016 22:55 #7888
It's absolutely annoying because you have to uninstall (by removing the add-on first), then re-install (yet again) the SDK.
We are going to remove installing the standalone add-on from the recommended workflow in the manual. Now the only benefit in the add-on is that its file size is much smaller than the SDK's.
Development Lead | Twitter
Please register or log in to leave a reply.