Forum

Can't install simple Blender Add-on

18 April 2015 00:24 #2082
For the small non-SDK Add-on 15.03 in Blender 2.74 on Windows 7 64X, error upon install from .zip file and trying to activate it in Blender:

ImportError: cannot import name ‘init_validation’

See enclosed screencap of error. Once it gave another error first but can't be reproduced.

Blender tech support ticket using the Report a Bug button says it's not a Blender error. However upon restarting Blender and starting again I then noticed an initially different error:

"TypeError: OpenKey() argument 2 must be str without null characters or None, not str"


I'm following the install instructions here:

https://www.blend4web.com/doc/en/first_steps.html

Will the full SDK install also allow simple export of an HTML file for web use, I wonder, assuming the big install might work?

EDIT: It installs just fine upon downgrading to Blend4Web 14.12 and Blender 2.72. Solved for now! Also worked for 15.01 and Blender 2.73 so I'm even up to the latest major version number.
20 April 2015 12:46 #2094
Hello,

This error is really pretty serious. Some users have already reported this issue, but we were not able to reproduce it on our Windows machines. It would be great if you pack your Program Files/Blender Foundation/Blender/ directory and your_user/App Data/Roaming/Blender Foundation/Blender and send to my email: evgeny-ar@blend4web.com. This way, we will be able to understand what stands behind this bug.
Blend4Web developer
08 May 2015 16:13 #2328
We believe this issue has been resolved in 15.04.
Development Lead | Twitter
28 July 2015 16:09 #3215
Hi,

thanks for your work, this addon seems really usefull.

Trying to install blend4web_15_06.zip on Debian 8 x64, Blender 2.74, activation after installing from file gives this error :

Modules Installed from '~/Download/blend4web_15_06.zip' into '~/.config/blender/2.74/scripts/addons' (blend4web)
Traceback (most recent call last):
File "/usr/share/blender/scripts/modules/addon_utils.py", line 306, in enable
mod = __import__(module_name)
File "~/.config/blender/2.74/scripts/addons/blend4web/__init__.py", line 36, in <module>
exec(import_module_script.format(m))
File "<string>", line 4, in <module>
File "~/.config/blender/2.74/scripts/addons/blend4web/properties.py", line 6, in <module>
from .interface import *
File "~/.config/blender/2.74/scripts/addons/blend4web/interface.py", line 9, in <module>
from . import ui_render
File "~/.config/blender/2.74/scripts/addons/blend4web/ui_render.py", line 9, in <module>
from .server import B4WStartServer
File "~/.config/blender/2.74/scripts/addons/blend4web/server.py", line 9, in <module>
import requests
ImportError: No module named 'requests'


Activation is cancelled. On immediate Activation retry, the error changes :

Traceback (most recent call last):
File "/usr/share/blender/scripts/modules/addon_utils.py", line 306, in enable
mod = __import__(module_name)
File "~/.config/blender/2.74/scripts/addons/blend4web/__init__.py", line 36, in <module>
exec(import_module_script.format(m))
File "<string>", line 4, in <module>
ImportError: cannot import name 'init_validation'


…so it seems related to this same issue.

Does any one has a solution to install the addon ?
How could I help debugging, or reporting the bug ?

thanks !

Victor
28 July 2015 16:55 #3216
Hello Victor and welcome to our forum!

The problem is about missing "requests" library, which is always included in the official Blender builds. Are you using some custom/non-official version of Blender?
Blend4Web Team
https://twitter.com/AlexKowel
28 July 2015 17:33 #3217
Hi Alexander, thanks for your quick reply !

The version should be an official 2.74 version, installed from Debian's package manager. Reinstalling from it doesn't solve the issue, neither resetting preference file.

The plugin installs well when blender is launched from the downloaded folders from blender.org, for both 2.74 (with same preference file) and 2.75a.

So it should not be a Blend4Web bug, and might be a Debian-packet Blender or config issue… I'll report back any more infos or solutions here.

Victor
28 July 2015 17:38 #3218
Yes, it seems that the library is missing. We've just added it inside Blend4Web distributions, please download and check our latest release candidate to confirm that the issue has been resolved.
Blend4Web Team
https://twitter.com/AlexKowel
30 July 2015 00:26 #3251
Installed the files from this repo https://github.com/TriumphLLC/Blend4Web with the installation steps.

The path for Blend4Web Add-on shows it is loaded from `Blend4Web-master/blender_scripts/` however the same errors show.

I guess it is a problem with my local Blender setup, and will post back if I find anything.

Meanwhile, testing Blend4Web from another Blender version is great.
30 July 2015 10:12 #3253
The problem should be fixed by now. Please try again either with our release SDK or updated github repo.
Blend4Web Team
https://twitter.com/AlexKowel
19 November 2015 06:20 #5067
I install Blend4Web Pro SDK v15.10 with Blend 2.7.6 on Window7 64bit. Get the error when activiate, below is the error screenshot
 
Please register or log in to leave a reply.