boolean animation

05 November 2015 15:49 #4810
yes without javascript my animation was working… It is just when I have added the javascript with the project manager, the problem starts.

After exported the project doesn't work
05 November 2015 15:59 #4811

It is just when I have added the javascript with the project manager, the problem starts.
Some servers disallow to serve unknown file extensions by default. A project can contain .mem, .json and .bin files which can be treated as suspicious by a server.

You can check it in the "Network" tab:

There should be 200 for all of the loaded data.
Blend4Web Team
05 November 2015 16:07 #4812
I have this so maybe there is a problem there
05 November 2015 16:22 #4813
Do you know how to solve this? I hope if I put it on a real server I will not have this problem
05 November 2015 17:01 #4814
OK, I get it. You haven't uranium.js and probably some other files that are needed to run an application. It's happened because you've chosen "export project archive" option. There is some confusion here. This option is intended for sharing a project between SDK's. Thus the project archive is not a fully working project itself.
We're still working on the project manager and we're planning to add some sort of "deploy" option.

There are 2 ways to fix your project:
1) You need to copy all the missing files to the server. They can be caught by observing the Network panel (at least that "canceled" uranium.js)

2) You can recreate your project as "Bundled", which will contain all it needs. So the "export project archive" option will work as you want.

Blend4Web Team
05 November 2015 17:58 #4815
Yes yes you got it Ivan!!!
Thank you so much for this answer that helped me so much!!
Problem solved!!
05 November 2015 18:02 #4816
Great! Good luck in your further work!
Blend4Web Team
07 January 2016 14:41 #6294
Hi the team! I have one new issue I cannot solve…I would like to know how to lock my papyrus because I can still move it with the left clic and that is not part of my project
I try to lock it in blender with the transform locks panel and also with a constraint limit location but doesn't work.
Does someone have an idea?
Thank you
08 January 2016 22:45 #6352
Hi, again!
Actually you're moving the camera not the papyrus itself. Try to set STATIC move style on the camera in Blender.
Blend4Web Team
11 January 2016 08:01 #6425
waw so sorry to ask silly questions like this
I always think why my object move so I focus on it but you were right it's the camera!
Thank you so much Ivan for your help
Please register or log in to leave a reply.