Forum

FK Animation won't load

14 September 2016 15:41 #11794
Hi there, thanks for your reply!

I changed the line in the scenes.js module in the directory blend4web_sdk_free –> src.
The documentation advises to execute a command in the SDK root, but being a total noob I have no idea what that means exactly. I assume I need to edit another file?

I also tried changing the speed inside the shader: I opened the caustics.glslf in textedit and changed #var CAUST_SPEED vec2(0.0) to #var CAUST_SPEED vec2(1.0), then exported the .html again from blender, but that didn't have any effect.

If you could point to some tutorial or give me some more detailed info that'd be awesome, as I obviously have no idea what I'm doing here

Thanks so much!
14 September 2016 18:38 #11800
Reply to post of user donjoe
Hi there, thanks for your reply!

I changed the line in the scenes.js module in the directory blend4web_sdk_free –> src.
The documentation advises to execute a command in the SDK root, but being a total noob I have no idea what that means exactly. I assume I need to edit another file?

I also tried changing the speed inside the shader: I opened the caustics.glslf in textedit and changed #var CAUST_SPEED vec2(0.0) to #var CAUST_SPEED vec2(1.0), then exported the .html again from blender, but that didn't have any effect.

If you could point to some tutorial or give me some more detailed info that'd be awesome, as I obviously have no idea what I'm doing here

Thanks so much!

As far as you use MAC, you just need to:
1) Open Terminal
2) Navigate to blend4web directory
3) Type: "make compile_b4w"
4) If you want to use html export, you also need to type "make compile_apps"
5) Wait for the compilation process to finish.

It might be required to install some dependencies described here.
Blend4Web developer
14 September 2016 23:23 #11805
Hello Evgeny, thanks again.

the ''make compile_apps'' command is not working, even after installing a number of the depedencies you linked to (bash doesn't exist for OSX though). I get the following error:

Williams-MBP:blend4web_sdk_free WilliamKlein$ make compile_apps
Compiling applications
—————————————
Project source directory does not exist
—————————————
———————————————————-
Try ' ./project.py compile –help' for more information.
———————————————————-
make: *** [compile_apps] Error 1
Williams-MBP:blend4web_sdk_free WilliamKlein$


You mentioned there was another way of achieving my goal by changing the speed value inside the shader. I did this in the caustics.glslf file via textedit, but that didn't seem to have any effect when exporting the html.

Any more ideas? I'm thinking I might better just leave this be, lol.
15 September 2016 12:46 #11813
Reply to post of user donjoe
Hello Evgeny, thanks again.

the ''make compile_apps'' command is not working, even after installing a number of the depedencies you linked to (bash doesn't exist for OSX though). I get the following error:

Williams-MBP:blend4web_sdk_free WilliamKlein$ make compile_apps
Compiling applications
—————————————
Project source directory does not exist
—————————————
———————————————————-
Try ' ./project.py compile –help' for more information.
———————————————————-
make: *** [compile_apps] Error 1
Williams-MBP:blend4web_sdk_free WilliamKlein$


You mentioned there was another way of achieving my goal by changing the speed value inside the shader. I did this in the caustics.glslf file via textedit, but that didn't seem to have any effect when exporting the html.

Any more ideas? I'm thinking I might better just leave this be, lol.
Thanks to you, we have found a bug in SDK CE application compilation script. We'll fix it in the nearest release.

Anyway, there is another option to recompile Web Player. Just go to the Project Manager main page. Find webplayer application and click the compile project button.

Now, you should see new caustics speed in HTML-exported files.
Blend4Web developer
16 September 2016 20:17 #11877
Well, I'm glad I haven't only been a nuisance!

I've got it working now with the .json export, still not the .html, but that's fine.

Edit: Question is redundant
21 September 2016 21:39 #11994
Edit: Question is redundant.
23 September 2016 01:37 #12032
Hi guys, quick question: is there an easy way of reproducing the effect seen in the 'forest on fire' environment demo? I think that might look cool for my underwater scene, but can't find out how it was done.

Thanks a bunch!
23 September 2016 10:47 #12037
Hey donjoe,
look through this post, there's a working example and a video explaining
3D Generalist, contests administrator,
Blend4Web team.
art blog: http://contret-art.tumblr.com/
24 September 2016 01:24 #12054
Hey, what an awesome tutorial video, really useful, thanks!

The heat effect works well on its own, but for some reason it messes up the depth of field effect when using .html export.
I can only get the two effects to work simultaneously when doing a .json export, but then my video texture disappears. I did package the .blend file, so I don't know why the .json scene can't find the .webm video file, maybe I need to put it in some special repository separately?

What is super weird is what happens when I export .html in blender 2.77a with both the depth of field and the heat effect turned on - take a look at my attachment, it actually looks quite cool, but super crazy, almost like the 'freestyle' rendering in blender's internal engine.

Any ideas on how to get around this or how to get the .webm video file working in my .json exports would make me a happy camper

cheers!
26 September 2016 11:20 #12079
Can you attach your .blend? We'll test it.

And which version of Blend4Web are you using?
And I didn't quite understand about video texture - it's in another file?
Try copying the video into the SDK directory and use it from here, it might help!
3D Generalist, contests administrator,
Blend4Web team.
art blog: http://contret-art.tumblr.com/
 
Please register or log in to leave a reply.